This is a notice that our eCommerce and custom applications and hosting services comply with the latest (as of 1/21/2018) Payment Card Industry (PCI) security standards including the exclusion of specific security/cipher protocols that are known to be vulnerable to various security breaches.

Some of our clients using credit card processing services such as PayPal and Authorize.Net may be receiving emails advising that credit card processing services may be disrupted if your commerce application does not comply with the new PCI standards including the omission of older security protocols including TLS v1.0, TLS v1.1, SSL v2 and SSL v3.

Currently all of our hosted services are using TLS v1.2 ONLY. This will be updated as newer, more secure and compatible protocols are released and tested.

You may refer to the online testing suite for your domain by visiting this link: https://www.ssllabs.com/ssltest/analyze.html

As a reminder, all of our solutions we provide to you are published using privately owned and managed servers and services. This allows us to create custom hosting environments that are unique to each application developed for your business while complying with the rapidly changing security environment on the world wide web

 



Sunday, January 21, 2018

« Back